fbpx

[Excel] La funzione SE in Excel

In questo tutorial vediamo come utilizzare la funzione SE in Excel. Si tratta di una delle funzioni più potenti ed utili che si possano utilizzare ed è spesso utilizzata insieme ad altre funzioni, anche annidate. Vediamo come la funzione SE in Excel permetta al foglio di calcolo prendere delle “decisioni” in base al verificarsi o meno di alcune condizioni.

Utilizziamo come metodo di spiegazione un semplice esempio: supponiamo di avere una lista di utenti che sostengono degli esami universitari. Dobbiamo usare Excel per identificare l’esito dell’esame che potrà essere PROMOSSO o RESPINTO.

La Funzione SE in Excel- Corso Excel a Firenze - Mummu Academy
La Funzione SE in Excel- Corso Excel a Firenze – Mummu Academy

Se dovessimo risolvere questo caso senza Excel, ma soltanto tramite una stampa su carta procederemmo come segue: analizzeremmo il voto presente nella cella B2 e se fosse maggiore od uguale di 18, ALLORA scriveremmo “PROMOSSO”, ALTRIMENTI scriveremmo “RESPINTO”.

Analogamente si potrebbe dire che SE il voto fosse minore di 18 ALLORA scriveremmo “RESPINTO”, ALTRIMENTI scriveremmo “PROMOSSO”.

SINTASSI DELLA FUNZIONE SE IN EXCEL

La sintassi della funzione SE è da un punto di vista logico-umano la seguente:

SE il test che eseguo e VERO, ALLORA eseguo un comando, ALTRIMENTI eseguo un altro comando.

Passando in una modalità ibrida uomo-macchina possiamo scrivere che:

=SE(il test che eseguo è vero; eseguo un comando; eseguo un altro comando)

Come si intuisce facilmente, il simbolo del “punto e virgola” identifica l’ALLORA e l’ALTRIMENTI. Più esattamente il primo “;” è l’ALLORA, ed il secondo “;” è l’ALTRIMENTI.

Questa funzione è in Excel la rappresentazione del ciclo IF-THEN-ELSE (SE-ALLORA_ALTRIMENTI) dei linguaggi di programmazione.

Tornando al nostro esempio dei voti possiamo formulare quanto segue:

=SE(B2>=18;”PROMOSSO”;”RESPINTO”)

analogamente

=SE(b2<18;”RESPINTO”;”PROMOSSO”)

Risulta chiaro che:

  • il TEST consiste nel verificare se sia VERO o FALSO il fatto che il voto sia maggiore o minore di 18.
  • il comando da eseguire quando il test è VERO consiste nello scrivere la parola “PROMOSSO”
  • il comando da eseguire quando il test è FALSO consiste nello scrivere la parola “RESPINTO”

Ricordiamo che i numeri generalmente non si mettono tra virgolette poiché verrebbero trattati come testo e non valori numerici.

La Funzione SE in Excel- Corso Excel a Firenze - Mummu Academy
La Funzione SE in Excel- Corso Excel a Firenze – Mummu Academy

Volendo utilizzare entrambe le formule aggiungiamo anche la seconda di cui abbiamo ipotizzato.

La Funzione SE in Excel- Corso Excel a Firenze - Mummu Academy
La Funzione SE in Excel- Corso Excel a Firenze – Mummu Academy

Copiando le formule verso il basso si ottiene quanto segue

La Funzione SE in Excel- Corso Excel a Firenze - Mummu Academy
La Funzione SE in Excel- Corso Excel a Firenze – Mummu Academy

Volendo utilizzare una formula che controlli se i due esiti fossero coincidenti si potrebbe scrivere:

=SE(C2=D2;”IDENTICO”;”DIVERSO”)

La Funzione SE in Excel- Corso Excel a Firenze - Mummu Academy
La Funzione SE in Excel- Corso Excel a Firenze – Mummu Academy

Le formule utilizzate fin qui ci hanno permesso di utilizzare sia confronti numerici che alfanumerici. Vediamo di seguito uno sviluppo del caso precedente che ci permetta di utilizzare anche i riferimenti assoluti oltre che quelli relativi.

LA FUNZIONE SE IN EXCEL ED I RIFERIMENTI ASSOLUTI PER I CONFRONTI TRA CELLE

Supponiamo che gli studenti promossi ricevano un premio di € 10, mentre gli altri di € 0. Avremmo il seguente scenario di partenza:

La Funzione SE in Excel- Corso Excel a Firenze - Mummu Academy
La Funzione SE in Excel- Corso Excel a Firenze – Mummu Academy

La formula che ci permette di determinare il premio per gli utenti è la seguente:

=SE(D2=”PROMOSSO”;10;0)

ci rendiamo subito conto che la formula, sebbene, corretta, può essere migliorata mediante dei riferimenti assoluti in

=se(D2=$I$2;$J$2;$J$3)

Mediante quest’ultima se gli importi dei premi cambiano, cambia anche il risultato della formula senza che si renda necessaria una sua modifica.

La Funzione SE in Excel- Corso Excel a Firenze - Mummu Academy
La Funzione SE in Excel- Corso Excel a Firenze – Mummu Academy

Per la comprensione di questo articolo mostra una delle funzioni spiegate nel nostro Corso di Excel a Firenze.

Per chi partecipa ai corsi di Mummu Academy, il materiale didattico di studio è sempre disponibile alla nostra piattaforma di studio.

 

Leave a comment

Il tuo indirizzo email non sarà pubblicato. I campi obbligatori sono contrassegnati *