[Excel] Funzione Somma.SE – Corso Excel a Firenze

In questo articolo vediamo come utilizzare una tra le le più importanti funzione di Excel. Vediamo infatti come ottenere dei subtotali attraverso la Funzione Somma.SE

Supponiamo di avere un foglio di calcolo all’interno del quale siano riportati gli ordini di alcuni venditori, suddivisi per Paese, Agente, Data Ordine ed Importo.

Funzione Somma.Se Corso Excel a Firenze a Mummu Academy
Funzione Somma.Se Corso Excel a Firenze a Mummu Academy

Come possiamo facilmente notare, i venditori possono vendere il loro prodotti in due paesi: UK ed USA.

Quello che ci chiediamo è come poter determinare quanto si è venduto complessivamente in UK ed USA senza ricorrere ai fastidiosi Copia-Incolla necessari se si utilizzano i Filtri Automatici.

La funzione Somma.Se permette proprio questo. Vediamo insieme come.

Scriviamo il testo “UK” ed “USA” in due celle diverse, ad esempio in F1 e G1, rispettivamente.

In F2 desideriamo trovare il subtotale delle vendite per “UK” ed in G2 quello per gli “USA”.

Analisi Logica della funzione SOMMA.SE

La funzione ripercorre idealmente il processo mentale che noi utilizzeremmo se dovessimo calcolare “a mano” i totali parziali.

Se per esempio iniziassi con “UK” procederei in questo modo: ogni volta che nella colonna del Paese trovo il valore “UK“, prendo come addendo il valore che si trova sulla stessa riga ma nella colonna degli Importi.

Terminato questo processo effettuerei la somma degli addendi individuati ed otterrei il valore delle vendite per “UK“. Potrei facilmente ripetere tale operazione per gli “USA“.

Per il processo in esame è necessario quindi individuare ed utilizzare due colonne o parti di esse:

  • la prima è quella dei nomi dei Paesi in cui vado alla “ricerca” del “matching” con il nome del paese per il quale desidero il subtotale. Ad esempio, nell’intervallo A2:A25 vado alla ricerca del termine “UK
  • la seconda è quella degli Importi nella quale prendo gli addendi ogni volta che al passaggio precedente ho il matching positivo (ogni volta, cioè, che trovo “UK“). Nel nostro esempio, ogni volta che trovo “UK” mi muovo sulla stessa riga di” matching positivo” e prendo il corrispondente valore dall’intervallo D2:D25

Importante e Fondamentale: in mezzo ai due intervalli si trova, idealmente, il “Criterio” per il quale desidero il subtotale. Nel nostro esempio il criterio è il nome del paese, ovvero “UK

Gli Elementi Logici della funzione sono quindi tre:

  • Intervallo di Confronto: dove cerco il matching per il Criterio
  • Criterio di Confronto: la voce per la quale desidero il subtotale
  • Intervallo degli Addendi: dove prelevo i valori da sommare

Sintassi delle funzione Somma.SE

La sintassi riutilizza gli elementi logici così come li abbiamo esposti ed è così strutturata:

=SOMMA.SE(intervallo di confronto; criterio di confronto; intervallo degli addendi)

Nel nostro caso, volendo determinare le vendite per “UK” nella cella “F2“, procedo come segue scrivendo la formula proprio in F2:

=SOMMA.SE(A2:A25;”UK”;D2:D25)

ci rendiamo subito conto che la forma sopra esposta è molto comprensibile ma è migliorabile in

=SOMMA.SE($A$2:$A$25;F1;$D$2:$D$25)

Funzione Somma.Se Corso Excel a Firenze a Mummu Academy
Funzione Somma.Se Corso Excel a Firenze a Mummu Academy

 

Copiando ed incollando la formula in G2 si ha che:

Funzione Somma.Se Corso Excel a Firenze a Mummu Academy
Funzione Somma.Se Corso Excel a Firenze a Mummu Academy

 

 

Avendo usato una formula con dei riferimenti assoluti e relativi soltanto gli intervalli rimangono “bloccati”, mentre il riferimento alla cella del criterio cambierà a seguito del copia incolla.

Chi frequenta il Corso di Excel a Firenze di Mummu Academy ha a disposizione il materiale di apprendimento di studio nella sua area riservata. Basta che si colleghi con il suo nome utente e password alla nostra Piattaforma di Studio.

Rispondi

%d blogger hanno fatto clic su Mi Piace per questo: